Simulation Forums

Find Simulation answers, share expertise, and connect with your peers

Simulation CFD

Problems getting results loaded

594 Views, 10 Replies
08/08/2013 8:54 AM


im pretty new to CFD simulation and tried to get into it  with Sim 360 student edition. however im having trouble getting the results loaded into sim cfd 2014.

I solved both on the cload and locally as the cloud told me i was out of cloud points ( although i should have unlimited as student or?) but both with both methods i have problems with getting the results. For the could it tells me its downloading the results, but nothing happens, no data transfer nor any updating when im opening the model with sim 2014.


With the locally solved models the sim job manager tells me the job has finished, but the results wont update within sim 2014 even as i had sim 2014 open all the time.

The models i use are not super complicaed ( atleast i think so) and big and im primary interested on the mixing of 2 fluids (water and a water like reagent) in different mixer designs for my thesis.

The flow is far into the laminar region with Re at about 50-350 at max, so im using the laminar flow turb. model and Advection Scheme 5 ( as far as i understood it thats the one to use for such pipe flows?)

im using both transient analysis and steady analysis. the steady one worked ok with solving and loading it, but with the transient on ive trouble.

As in transient analysis the flow should be pulsed im using 2 transint  bc for modeling the pulsed flow: a harmonic one and a stepwise linear profile which i gained from a velocity profile of  a membrane pump.

As the mixers im using are only 30mm in length and i got a peak velocity of 0,4m/s im using pretty small time steps of 0.0005s with 10 iterations for each step.

for learning how to use CFD i tried to simulate a simple Y-Junction with 2 Inlet Volume flow BC and 2 inlet skalar BC (0/1) to simulate the 2 different fluids for mixing and one 0 pressure BC at the outlet.

like it said it works when im simulating it in steady state and it converges after about 150 iterations, but the transient ones are running but never finishing or downloading, although Sim job manager tells me its complete.

I think its either something with my setup, or is it a software issue?


hope you can help me

Report Inappropriate Content
Message 1 of 10 ( Views: 594 )

Re: Problems getting results loaded

09/04/2013 12:17 PM



I am just looking over the older posts here which had no replies, was this resolved in the end?


Are you saving a large number of save intervals? This is a potential cause I would have thought.


Kind regards,


Report Inappropriate Content
Message 2 of 10 ( Views: 543 )

Re: Problems getting results loaded

09/04/2013 1:46 PM


yes im using quite alot of timesteps. iam simulating a 4 sec long scenario with a stepsize of 0.0025 and saving every  0.01 sec , so ive 400 saved timesteps for the full scenario. my stepsize need to be so small because iam simulating a quite small part of only 40mm pathlength but a peak velocity of 300-400 m/s.

its not exaclty solved but i got a kind of "workaround" with which it works most of the time. for me the problem seems to be a mix of hardware limitations on my side and some data exchange issue between the job manager and cfd 2014.


workaround consists of starting the simulation and waiting until the job manager finished uploading the data to the cloud. then i have to exit the scenario and have to wait until the scenario is fully solved (or failed :) ) and completly downloaded so that the job manager shows it under finished.


when im now opening the scenario with cfd 2014 it takes a long time, but it will be loaded most of the times, although it can happen that CFD 2014 crashes during the opening/loading process. But its kinda hard to differ between a crashed CFD 2014 and a still working CFD 2014 because windows shows it in both cases as "not responding" for quite a long time.


when iam not exiting the scenario after it was uploaded on the cloud and the job manager imports the partly solved time steps into CFD 2014, then it stops loading the results somewhere inbetween and it wont start it again even if the job manager finished downloading all the data.

same happens if CFD 2014 or the jobmanager crashes when the loading/solving/downloading is not finished.



so when it comes down to it loading the results works for me when iam not opening the scenarios until the jobmanager hast completly finished them, but it realy slows down the workflow as ive to use a new project for every scenario as i cant open the scenarios independently ( when you have more than one scenario in a project there will be always opened the last active scenario even if you want to open another one via the job manager)


kind regards




Report Inappropriate Content
Message 3 of 10 ( Views: 534 )

Re: Problems getting results loaded

09/04/2013 1:53 PM

This might be part of the issue - we typically recommend saving no more than about 50 timesteps at the most, I assume the final file size is pretty large, which means a lot of data to move around.

Do you find this issue is still present with simple, non transient models?

Best regards,

Report Inappropriate Content
Message 4 of 10 ( Views: 532 )

Re: Problems getting results loaded

09/04/2013 2:06 PM


just see it wrote m/s instead of mm/s, but still.


no steady analysis of the same part works fine, but doesnt help me alot in this case, as ive got a pulsatile flow of 2 pumps pumping with 1hz and 500ms offset to each other and im interested in the resulting mixing.


yeah theres alot of data shuffled around, got several gb of data.

the job manager does kinda weird saving by the way. Ive seperated an extra partition for saving the data for the job manager, but the job manager still downloads the data first to the windows partition and saves the data in a tempory folder. after it has finished all the downloading in copies the data from the temporary folder on the windows partition into the designated folder on the "jobmanager partition".

This basicly eats twice the amount of disk space as necessary and copying all the data also takes alot of time because of the size (didnt got an ssd)



i have also tried to solve te simulation step by step with only solving 0.5 Seconds a time, but then i got the same problem as before than after some time CFD 2014 just stops loading the new data

Report Inappropriate Content
Message 5 of 10 ( Views: 525 )

Re: Problems getting results loaded

09/04/2013 2:16 PM
OK, at least we know then that it is the model size that is the bottleneck. Try a few less save intervals next time if you can and see how it performs?

Yes, you are correct about the file downloading and moving. You should at least be able to change this location though, within the job manager settings - not sure if this will be useful or not as it does not cut down on the data.

I am not sure I understand your last point, if you increase the timestep too far, CFD would struggle to capture the simulation correctly.

Report Inappropriate Content
Message 6 of 10 ( Views: 519 )

Re: Problems getting results loaded

09/04/2013 2:30 PM

ive already switchted the save location in the job manager, i was just wondering why the job manager just doesnt download directly into this location.



in my last point i mean, that ive broke up the 4 seconds of my full simulation in 0.5 second parts, because i already assumed that the data size is part of the problem. i didn changed the stepsize or saving interval, just didn simulated the full 4 seconds i want to investigate in one part.


so ive startet a simulation with the first 0.5 seconds which means 50 save intervals. after finishign this ive startet a new simulation of the next 0.5 seconds, but this time the simulation starts at 0.5 seconds, so that after the 2nd simulation run i got 1 second simulated. and continueing this until ive got 4 seconds simulated but this time in 8 smaller simulation runs of 0.5s instead of one big 4 second run.


but as i said it didn worked as after a few runs the new results didn load anymore even if i give CFD 2014 two days time over the weekend.



hope this clears out my last point



Report Inappropriate Content
Message 7 of 10 ( Views: 516 )

Re: Problems getting results loaded

09/04/2013 2:35 PM
I think the issue is still probably the final file size, as you eventually have all of the timesteps saved within the single analysis right?
Could you save out less overall steps at all? Perhaps this would not provide you the detail you need though..

Report Inappropriate Content
Message 8 of 10 ( Views: 514 )

Re: Problems getting results loaded

09/04/2013 2:44 PM

yeah less save intervalls could be a solution but like you said i would loose the detail.


well as my "workaround" works most of the times ill be sticking to it, better a slow workflow than none.



Report Inappropriate Content
Message 9 of 10 ( Views: 505 )

Re: Problems getting results loaded

09/09/2013 6:59 AM

I have noted this same behavior of Autodesk doing multiple reads and writes.


1.  Simulation Job Manager will write delta.zips to the ~User/Appdata/Temp folder.

2.  The same delta.zips will then be written to ~User/Appdata/Autodesk/Simulation Job Manager/2013/Storage

3.  Simulation Job Manager will then write the file to the Cache folder that is designated in the Simulation Job Manager GUI.

4.  The delta.zips are then decompressed and written to the actual simulation folder location.


This is hokey.  I have a good SSD and a Ivy Bridge quad core processor with 32 GB RAM and the Sim CFD and Simulation Job Manager windows will become unresponsive for a time.  


Of course, this 'frozen window' is a welcome problem as it means that the results have actually been downloaded.  As it is, I'm usually looking at Simulation Job Manager spooling up a few hundred TCP connections and then trickling results along at about a 100 Kbps pace ... and I know there's GB's of data waiting out there on the servers.  FYI, my connection is now a 5 Mbps low latency connection that's designed for teleconferencing and VOIP lines ... ie the ISP says it's not the bottleneck.


I've talked a lot with support about this.  There's been sympathy but no promise of a coming fix.  I was told to 'limit my simulations' but that's not exactly an 'unlimited' product then no?   


I think that the Simulation Job Manager team was able to run like a 200k element simulation on the cloud (just one at a time!) and thought that was good enough for a shipping product.


A great physics package, but Simulation Job Manager architecture and code...well... I'll stop there.

Report Inappropriate Content
Message 10 of 10 ( Views: 484 )